
Odyssey Writer 

 

Odyssey Writer is a customizable writing tool in Odyssey Manager that helps educators in all disciplines teach 

the writing process to their K‐12 students. Designed to improve narrative, persuasive, informative, fiction, 

and nonfiction writing skills, Odyssey Writer lets teachers create and assign writing assignments and guides 

students through the entire writing process. Students are encouraged to monitor their progress via 

assessment tools, such as state writing rubrics and checklists. Odyssey Writer’s features empower teachers 

to create and assign writing assignments that meet national and state standards. 

How do I use Odyssey Writer? 

When students log into Odyssey, they will see a student launch pad that corresponds to their grade level (set 

in their student profile). Odyssey Writer buttons also corresponds to the student’s grade level. 

 

 
 

Students may launch Odyssey Writer when they complete an Odyssey Writer assignment; or students may 

start the tool by clicking the launch pad icon. When a teacher returns a graded Odyssey Writer assignment to 

a student, the icon below the Odyssey Writer is animated.

 
NOTE For grades PreK–2: Odyssey Writer is available on the student launch pad only after the teacher has 

evaluated and returned the student’s first Odyssey Writer project.

 
The following example displays an Odyssey Writer assignment for a student in grade 5. The assignment 

includes a teacher prompt that the student sees when the assignment is first opened. 
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What forms of writing will students use in Odyssey Writer? 

Odyssey Writer aims to improve students’ writing skills in all forms of writing. The following are descriptions 
of some forms of writing students will use in Odyssey Writer. 
 
Narrative 
In narrative writing, the author tells a story or an account of events or experiences. Narrative writing can be 
either fiction or nonfiction. Some examples of narrative writing are novels, biographies, and some poetry. 
 
Persuasive 
In persuasive writing, usually the author is clearly arguing for or against a position. Persuasive writing tries 
to influence the reader to think or act a certain way. It attempts to sway the reader’s opinion. Some 
examples of persuasive writing are found in political speeches, advertisements, and editorials. 
 
Informative 
Informative writing conveys an author’s knowledge of objects, events, and ideas, without expressing his or 
her feelings or attitudes. By focusing on facts, it explains how to do something, what something is like, or 
what someone has done. Examples of informative writing are news articles, instruction manuals, textbooks, 
and “how to” guides. 
 
Fiction 
Fiction writing is speculative and make‐believe. An author’s imaginary experiences can be set in the past, 
present, or future. Often, the purpose of fiction writing is to entertain, but authors sometimes use fiction 
writing to symbolically teach a moral or state an opinion. Some examples of fiction writing are science 
fiction, fairy tales, fables, and tall tales. 
 
Nonfiction 
Nonfiction writing is narrative prose based on facts and reality. Nonfiction writing is an unbiased, factual 
account of events. Some examples of nonfiction writing are biographies, historical articles, and essays. 

What are the stages of the writing process used in Odyssey Writer? 

Odyssey Writer guides students through each stage of the writing process: prewriting, drafting, revising, 

editing, and publishing. Here are brief descriptions of each of these stages, as well as a few suggestions for 

teachers. 

 

Prewriting 

The prewriting stage allows students the opportunity to brainstorm and start forming a plan for their writing 

assignment. 

 Teachers can write questions that help prepare students for their writing assignment. 

 Teachers can also give students partially completed note cards to fill in or can ask students to develop 
the note cards or graphic organizers themselves. 

 Outlines help students to collect information relevant to their writing topic and to organize their 
thoughts. 

 Students can also use graphic organizers to jot down ideas during the prewriting stage. The Graphic 
Organizer and Note Cards tools are synchronized with the outline. The outline can then be pasted to the 
Drafting tool for students to expand on their writing. 

Drafting 

Drafting is the beginning of the final product, which is usually a project. Students concentrate on 

organization, supporting details, and coherence of their entire composition. They can express their thoughts 

freely, since the software tools make rewriting and revising easy to do. You can remind students to express 

all ideas in sentences and paragraphs when writing a draft. 



 

Revising 

When students have finished their drafts, they can evaluate their projects using a self‐assessment and 

rubric. Students can then revise their projects accordingly. 

 

Editing 

Editing includes correction of punctuation, spelling, capitalization, sentence structure, word selection, and 

so on. Students can also cut and paste text to change the order of their words, sentences, or paragraphs. 

 

Publishing 

Publishing is the process of creating the final product for the intended audience. Students can use desktop 

publishing features, such as centered and boldface type, to make their projects look polished. 

How do I assign Odyssey Writer projects? 

Areas of the Odyssey Writer interface—Instructions, Writing Framework, Note Cards, Web Links, and Rubric—

allow teachers to customize assignments. When teachers first launch Odyssey Writer, they will see the 

Odyssey Writer screen with the Instructions tab displayed. 

  
 

When you save an Odyssey Writer project, your target folder determines who will have access to the project. 
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How do I create an Odyssey Writer project? 

1. From the navigation bar, select Assignments -> Assignment Builder. 
2. With the Curriculum tab selected, click Create Custom Activity. 
3. In the Create Custom Activity dialog box, select Odyssey Writer Activity and click Next. 

Odyssey Writer opens with the Instructions tab selected. 

 
NOTE Instead of creating a project from scratch, you can edit a copy of a project. See Using an Existing 
Project as a Template. 

 

4. If desired, include instructions for students to read when they first start the Odyssey Writer project. 
5. To include prewriting and draft writing support, click the Writing Framework tab and enter the desired 

information. 
6. To create note cards, click the Note Cards tab and enter note card and pinpoint text. 
7. To include web links that students may visit as they work on their projects, click the Web Links tab and 

enter titles and URLs. 
8. To use a rubric, click the Rubric tab. You can use an existing rubric or create a new one. See Using an 

Existing Rubric or Creating a New Rubric. 
9. When you are finished creating the new Odyssey Writer project, click File -> Save. 
10. In the Save Project dialog box, click the desired folder in which to save the project, remembering that 

you must have permission to save to the District and School Projects folders and that you cannot save to 
the Odyssey Projects folder.

NOTE Saving a project in the My Projects folder restricts access so that only you can see and copy the 
project.

 
11. Turn spell check On or Off. 
12. If desired, set Draft Mode to Yes.

NOTE You cannot assign a project that is in Draft Mode. When you are ready to assign the project, open 
the draft, make any changes, and then Save As (renaming the project). Ensure that Draft Mode is set to 
No.

 
13. Select the Subject and Grade. 
14. Enter a name for the project; click Save; and then Close. 
15. To make the project available for an assignment, click Send to Assignment Builder. 
16. Click Close and then Exit. 

Assignment Builder displays your new Odyssey Writer project. You can continue to add curriculum or 
complete the assignment. See Task 2: Refine the Assignment. 

How do I use an existing project as a template? 

1. With Odyssey Writer open, select File -> Open. 

The Open Project dialog box displays a list of your projects, if any, from the My Projects folder. 

2. If the project you want to use is in a different folder, open the desired folder—District Projects, School 
Projects, or Odyssey Projects—remembering that you need permission to access the District Projects and 
School Projects folders. 

3. Select the desired project and click Open. 

Odyssey Writer displays the project for you to edit and save as a new project. 
 



How do I create web links on the Instructions screen? 

1. From within the Odyssey Writer project, click the Instructions tab. 
2. Highlight the word or sentence that you want to appear as a link. 
3. From the Odyssey Writer menu bar, select Insert -> Hyperlink. 

The Insert Hyperlink dialog box is displayed. 

4. Type the web address and then click OK. 

The highlighted text becomes a hyperlink. When students click on the link in their draft (displayed in the 
Drafting tool), a new browser window opens to the linked page. 

5. To change the web link, select the link text and then Insert -> Hyperlink. 

How do I add images and equations in Odyssey Writer? 

You can add images or equations to the Instructions and Writing Framework screens. As you work with 
images and equations, note the following: 

 To add text beside or below an image or equation, place the cursor beside the image or equation and 
press Enter (on the keyboard) until the cursor is in the desired location. 

 To move an image or equation, click the image or equation to display sizing handles and a Move button. 
Single‐click Move and then click in the area of the desired move location in the screen. 

 To remove an image or equation, single‐click the image or equation and press Delete (on the keyboard). 
After you delete an image or equation, you may need to adjust the spacing of remaining text. 

How do I evaluate Odyssey Writer projects? 

Teachers can access submitted Odyssey Writer projects in these ways: 

 Selecting Assignments -> Submitted Projects from Odyssey’s main menu. 

 Selecting Assignments. From the Assignments home page, the Submitted Projects button becomes 
animated if submitted but unopened projects are awaiting the teacher’s attention. 

 
When Odyssey Writer opens, the Submitted Projects dialog box displays a list of projects that students have 
turned in. 
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TIP To display a list of all submitted projects—evaluated and unevaluated—first close the Submitted Projects 
dialog box. Then, select File -> Open.

When a teacher opens a project to evaluate, the student’s work is displayed (at right) with the teacher’s 
rubric open (at left). 

 

What is a rubric? 

A rubric is a scoring tool that allows teachers to assess student projects by measuring them against scoring 
criteria. A rubric may include up to eight scoring sections with a maximum of six criteria per section. 
Numbers displayed across the top of the rubric panel represent categories of the rubric. An example of a 
rubric category is Conventions. 
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 To evaluate with a rubric, select the appropriate number for each category. 

 To advance to a different category, click a number in the white square. 

 To view the self‐assessment rubric the student used, click the self-assessment button. 

 To return to the teacher’s version of the rubric, click the teacher evaluation button. 

 

How do I use an existing rubric? 

1. With Odyssey Writer open, select the Rubric tab. 
2. Click Open Rubric. 

The Open Rubric dialog box displays any existing rubrics you have created in the My Rubrics folder. 

3. To select a rubric from the My Rubrics folder, click the desired rubric. 
4. OR 

To select a rubric from the District, School, or Odyssey Rubrics folder, click the folder and then the 
desired rubric. 

 
NOTE You must have permission to access the District and School Rubrics folders. 

 

5. With the desired rubric selected in the Open Rubric dialog box, click Open. 

The contents of the rubric you selected are populated in your new Odyssey Writer project. 

6. If desired, make changes to the rubric. 
7. When finished, click Save Rubric. 

The Save Rubric dialog box is displayed. 

8. Click the desired folder in which to save the rubric, remembering that you must have permission to save 
in the District and School Rubrics folders and that you cannot save to the Odyssey Rubrics folder. 

NOTE Saving in the My Rubrics folder restricts access so that only you can see and copy the rubric.

 

9. Give the rubric a name; click Save; then Close. 

How do I create a new rubric? 

1. With Odyssey Writer open, select the Rubric tab. 
2. Click New Rubric. 
3. Define each category and the performance you expect for each level of quality. 
4. When finished, click Save Rubric. 
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The Save Rubric dialog box is displayed. 

5. Click the desired folder in which to save the rubric, remembering that you must have permission to save 
in the District and School Rubrics folders and that you cannot save in the Odyssey Rubrics folder.

NOTE Saving in the My Rubrics folder restricts access so that only you can see and copy the rubric.

 
6. Give the rubric a name; click Save; then Close. 

How do I assign a grade? 

1. To display the Grade tool, click . 
2. From the pulldown menu, choose a grade. Available grades are A+, A, A‐,B+, B, B‐, C+, C, C‐, D+, D, D‐, 

and F. 

 

How do I view and create teacher comments? 

Teachers can use the Comments tool to write general comments about the student’s work. 

1. To display the Comments tool, click . 
2. From the displayed Teacher Comments box, type comments for the student to read after you have 

evaluated and returned the project. 

How do I use annotations in Odyssey Writer? 

Teachers can use the Annotations tool to include notes and annotations to 
specific parts of the project. 
 

To display the Annotations tool, click . 
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Common errors include: 

 Spelling errors 

 Capitalization errors 

 Run‐on sentences 

 Subject/Verb agreement 

 Usage errors 

 Punctuation errors 

 Sentence fragments 

 Improper use of commas 

How do I return an evaluation to the student? 

After you have finished evaluating a student’s Odyssey Writer project, you will return the evaluation to the 

student by clicking the Send button . The Submitted Projects dialog box is displayed, letting you 

select another project to evaluate. 
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